User Tools

Site Tools


gedit

Using the Gedit text editor

To open Gedit press:

Control + Alt + G

If you are coming from Windows and are used to using Wordpad you are in for a treat.

Gedit is highly configurable. If you press:

Alt +F

you will be taken to the File menu. Most of the options here will be familiar to you but the keyboard shortcuts may seem a bit different. Also, there is the addition of close

Control + W

When you open Gedit you can have several files opened at once. Instead of opening each file in a different copy of Gedit they all open in the same one. You can switch between the open files using

 Alt +1 
Alt + 2
Alt + 3 etc

If you would like to close the currently focused file press:

Control +W

or select Close from the File menu. Be sure to explore all of the menus to learn all about this powerful text editor. It even has a spell check option under the Tools menu. Explore the Preferences option located in the Edit menu as well. Gedit has the power to auto-indent, show line numbers and a lot more.

if that's not enough, it is extendable with plugins. They can be enabled and disabled in Preferences under the Plugins tab. One more difference in gedit is the Find dialogue. It is not located in the Edit menu but rather in its own menu called Search. To access it press:

Alt +S

There are several different options here including the ability to go to a specific line number. If you are just searching for some specific text you can do it even more quickly by pressing:

Control +F

type the text and press Enter. To search for the next occurrence press:

Control + G

The user manual for gedit is available by pressing:

F1

this is where you can get a list of the shortcut keys.

Tip: Using the Spell Checker in Gedit. Before using the spell-checker, check the language setting on the tools menu:

Alt +T

This setting determines which dictionary gedit will use when you spell-check and the name of your user dictionary. You can find your user dictionary in the hidden folder ~/.con fig/enchant. Important: the country component of the dictionary file name is in upper-case. For example, a user dictionary for UK English is en_GB.dic - the user dictionary file is a text file and can be edited with Gedit itself.

gedit.txt · Last modified: 2013/07/03 14:27 (external edit)